Plough => Ruby

Journey through ruby

Yarn Install on Mojave

If you’re having issues in yarn install on Mojave, then it’s probably down to the fact that Mojave doesn’t support different i386 architecture and anything that involves native building, gems or node modules, seems to fail. The solution is to clean the slate and start fresh. That’s exactly what I had to do to fix the yarn installation errors:

1
2
3
rm yarn.lock
yarn cache clean
yarn install

These commands worked like a charm!

Hope it helps!